PDA

View Full Version : layout very strange



tombigdaddy
15 Dec 2005, 06:58 AM
the problem: been laying out my new site - not doing too well so far...
linky here (http://www.waako.info/new/main.htm) in IE it's all over the place and in FF it spreads down the page. I'm on a Mac, so IE was a screenshot from a friend.

here is the CSS, full of errors I am sure, haven't touched any in a bit which doesn't help:



body {
font-family: Verdana, Geneva, Arial, helvetica, sans-serif;
background: #006699 url(images/background.gif) repeat-y center top;
margin: 0px;
}

td {
font-family: Verdana, Geneva, Arial, helvetica, sans-serif;
}

th {
font-family: Verdana, Geneva, Arial, helvetica, sans-serif;
}
a:link {
text-decoration: none;
}
a:visited {
text-decoration: none;
}
a:hover {
text-decoration: underline;
}
a:active {
text-decoration: none;
}
.smalltxt {
font: Verdana, Arial, Helvetica, sans-serif;
font-size: x-small;
color: #006699;
}
.topmenu{
font-size: 11px;
font-family: Verdana, Arial, Helvetica, sans-serif;
color: #FFFFFF;
}
#body {
width: 760px;
padding: 0px;
top: 0px;
}
#top_nav {
background-color:#006699;
position: relative;
left: 558px;
width: 200px;
height: 20px;
}
#top_nav li {
display: inline;
list-style-type: none;
}

#left{
width: 150px;
height: 110px;
top: 300px;
left: 5px;
position: relative;
}
#contact_frame {
background: url(images/contact_frame.gif) no-repeat;
width: 141px;
height: 107px;
position: relative;
padding-top: 8px;

}


Also here is the html:

<body>
<div id="wrapper" align="center">
<div id="body" align="left">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="160" height="310" align="left" title="menu">
<param name="movie" value="flash/menu.swf" />
<param name="quality" value="high" />
<embed src="flash/menu.swf" width="160" height="310" align="left" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed>
</object>
<div align="center" class="topmenu" id="top_nav">home :: sitemap :: contact </div>
<div id="left" align="center">
<div class="topmenu" id="contact_frame">
</div>
<div class="smalltxt"> waako 2005 </div>
</div>
<img src="images/productions/carmen.jpg" alt="Carmen" />
</div>
</div>
</body>

Gage8
16 Dec 2005, 12:03 PM
what is your DOCTYPE?

it should be something like:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

if it is not correct then each browser will default to their buggy ways of interpreting your css.